Interruption in Build Service
Incident Report for ConanCenter
Resolved
The previous incident related to Linux node is now fixed and this incident resolved.

Thank you for your collaboration.
Posted Sep 27, 2023 - 14:50 UTC
Monitoring
We have successfully resolved the Linux issue that arose, which was primarily linked to a plugin problem following a recent update to a newer version.

Nonetheless, we will maintain the current "Under Maintenance" status temporarily. This allows us to perform an update for zlib since it now supports version ranges. This update will not only address the affected recipes in CCI but will also follow the proper build order. Once this process is complete, any errors related to missing dependencies related to zlib should be resolved.

We sincerely appreciate your patience throughout this process. Thank you for your understanding.
Posted Sep 25, 2023 - 15:35 UTC
Update
Issue identified, remedial action taken and deployed.

The team will be thoroughly testing the service internally, before allowing incoming PRs in `conan-center-index` to be built automatically. Please reach out to a member of the Conan Center team if you have a PR that requires priority.

Once the service is resumed, please note that the system can relaunch PR jobs in a staggered way. Please do not close and re-open PRs to jump the queue as this can overload the service.
Posted Sep 25, 2023 - 12:23 UTC
Identified
The issue has been identified and the team is working on a fix.
Posted Sep 22, 2023 - 12:35 UTC
Investigating
There is currently a disruption affecting all builds for Pull Requests in Conan Center Index. This is affecting the provisioning of Linux agents (which are used for all builds, regardless of whether or not the recipe supports Linux).

The team is currently investigating. Conan Center and its website remain operational without issues to report.
Posted Sep 22, 2023 - 08:45 UTC
This incident affected: Conan Center Index Build Service, Conan Center Web UI, and Remote at center.conan.io.